Sign In

Allison Mankin

PCH Director of DNS. Applied research and Internet security and privacy executive. Inclusive teams. Internet pioneer.

Allison Mankin is an accomplished leader and expert in the fields of DNS, network security, privacy, and standards engagement. Her recent contributions in standards include authoring RFCs related to DNS Privacy such as RFC 9250, RFC 9103, RFC 8932, RFC 7858, and RFC 7766. With a strong background in networking, Allison has played a vital role in advancing Internet technologies such as IPv6 and Internet multimedia foundations. In 2021, Allison was inducted into the IPv6 Hall of Fame in recognition of her significant contributions. Allison holds a diverse educational background with studies at Princeton University, Northeastern University, University of Pennsylvania, and Massachusetts Institute of Technology.

Highlights

Feb 23 · linkedin

The 2024 DNS and Internet Naming Research Directions (DINR) virtual workshop will be a forum to discuss the research landscape around DNS and Internet naming – what are the important problems we need to tackle and what are the tools you need to get there? Short submissions are due on March 4 and the virtual workshop will be on April 4. This is a great forum for DNS, DNS security and privacy, and Internet Naming researchers to interact in. I'm eager to see what people want to talk about. All the details and the link to submit are at:

Aug 31 · linkedin

Deadline September 1: the IRTF is pleased to offer a number of Diversity Travel Grants to support early-career academics and PhD students from under-represented groups to attend the IRTF meetings co-located with the IETF-118 Meeting in Prague in November 2023.

More details at

Allison Mankin
Add to my network

Location

Washington DC-Baltimore Area